Depuis quelques jours, les boutiques sous PrestaShop 1.3 à 1.7 subissent des attaques depuis le formulaire de création de compte clients.

Comme le captcha de Google ne suffit pas, je vous donne une solution qui fonctionne.

Voici la procédure :

Crée un fichier que vous nommerez Validate.php que vous mettrez dans /overide/class/…

Dans ce fichier vous mettrez :

Ensuite

Crée un fichier que vous nommerez Costumer.php que vous mettrez dans /overide/class/…

Dans ce fichier vous mettrez :

Pour finir, allez dans /cache/… et supprimez le fichier cache_index.php

Et voila, normalement, vous n’aurez plus ses inscriptions fantômes.

Vous êtes pressé? Téléchargez directement les fichier en cliquant sur leur nom : validate.php – Costumer.php

!! Vous trouverez un autre fichier nommé ContactController.php dans le dossier overide/controllers/front/. Ce fichier est un complément qui bloque d’office les adresses email en .ru, .vn, .etc….

Vous trouverez une solution pour la version PrestaShop 1.7 sur le blog de mon ami Webbax

Si vous avez des questions ou simplement envie d’une aide pour l’installation de ses fichiers, n’hésitez pas à nous contacter.

A bientôt pour de prochaines aventures

error: Site protégé contre les copieurs !!
%d blogueurs aiment cette page :